Sunday, 5 January 2014

TNDJG:006:Carlsbro Sidewinder Persistent Reverb Fault

My friend has a Carlsbro Sidewinder guitar amplifier on which the reverb valve keept blowing every few months.  He replaced it twice and it went again so he asked me to have a look at the amplifier to see if there was a fault with it.

Pulling out the front panel reveals that the preamp uses four ECC83 double triodes:

One of these is for the springline reverb with one half driving the send through the small yellow transformer and the other being the return amplifier.  Banging the springline gives the normal clanking sound through the speaker which showed that the return side was working fine.  However, there was no signal on the send side, as revealed with a quick look using the oscilloscope.

A word of warning:  this amplifier has two on/off switches.  If you turn them both off at once, the high-tension is disconnected and is not discharged.  It sits at about 480 volts almost indefinitely. After my first shock I thought about fitting a 1 Mohm discharger resistor for safety but then I discovered if you switch it off on the mains switch while leaving the HT switch on then the HT is discharged while the valves still have some heat in them. So I decided to leave this aspect of the amplifier unmodified and keep the HT switch on all the time while working on the unit.

Diagnosing the problem

A quick measure of the electrode voltages on the reverb valve send side did not look healthy.  They were
  Anode:  496V and
 Cathode: 0.2V.

The grid was at 0V, the cathode bias resistor was 470 ohms and the primary of the output transformer was 560 ohms.   Replacing the valve restored operation and resulted in the anode being at  494V and the cathode at 2.1V.  This means the replacement valve was running at roughly 4mA x 500 V = 2W.

Looking more carefully at the circuit I saw that the other seven anodes in the preamp used an HT feed that came from the power amplifier.  This was at 350 volts or so.   It comes along the little cable that caries the line out from the preamp to the power amplifier; a cable that also carries a -50 volt bias rail.

On the other hand, the reverb driver was fed directly from the main HT voltage for the power amplifier, accessed via a wire link to the output side of the HT on/off switch.  I mentioned this to my father, who has designed many valve circuits and he immediately spotted a potential design fault in this amplifier: many versions of the ECC83 have a recommended maximum nominal anode voltage of 400 volts with 500 Volts and 1 Watt being the absolute maximum ratings under all circumstances.

Clearly the new valve would not last long either!

Fixing the problem

  The fix for the problem, as my father put it, was to "lose 200 Volts or so". An easy way to do that would be to wire the reverb send to the lower tension supply, but this was likely to overload that supply and it was presumably for that reason the designers at Carlsbro connected the reverb send to the main HT in the first place.

Since the anode feed came through a wire link, the obvious fix was to replace the link with a dropper resistor and to rebias the valve with a new cathode resistor.  The nominal valve plots above show that for 4mA the anode should be at 250V and the cathode at 0.5V.

The parts needed are as follows:

  • A new anode resistor:  60K ohm, 1 Watt (made from 27K+33K 0.5W resistors in series.
  • A replacement cathode resistor 165 ohms (two 330R in parallel).
  • A replacement ECC83 valve (hard to come by now - Farnell, CPC and Maplin no longer stock, neither does GEE in Cambridge, so purchased for £15.00 in PMT East Road Cambridge).
  • An anode supply capacitor: I used 150 uF 400V that I had to hand, but a lower capacitance would be fine and preferably a 500V capacitor should be used so that it would not be over-volted if the send valve is removed or failed again.

Here the wire link for the anode supply is removed (dotted line to right of large blue supressor capacitor (that is across the HT on/off switch poles):

Here the new anode resistor is fitted (I moved the suppressor to the left using the handy hole in the PCB for a larger physical suppressor):

Here I have started making a cradle for the new anode capacitor.  These two pots have four large lugs to the PCB and using the top of them as well I had six fixing points for making a snug capacitor bracket using tinned copper:

Here is the anode capacitor installed and you can also see the replacement cathode resistor parallel pair (between the valve and the xformer):

To wire the anode capacitor to the track between the anode resistor and the top of the xformer I drilled a small hole in the PCB (not shown) and passed the wire through the hole for easy soldering on the track side.

New operating Point

Measuring the new operating point for the valve we have
   HT Supply 494V 

   Dropped HT Supply: 265V

   Anode:  262V

   Cathode: 0.56V.

The new current is 0.56V / 165 = 3.4 mA which is about the same as before but the valve power is now 0.86 Watts which should not blow it.


Well it all seems to work fine at the moment.  I suppose there is the question of whether the reverb send will suffer transient clipping with its lower headroom but this really does not matter since the springline will be very good at rounding off such corners!
I hope you find this useful and if you try it yourself then do watch out for the high voltages!



ControlSurface-Daemon: A Mapper Daemon for Novation Control Surfaces and others where management is needed.

A daemon that exports an ALSA midi client that speaks over a private USB connection to a studio control surface.

The source code for this mini-project is here.  Please let me know if you find it useful or enhance it.  My apologies for its quality: it was written very quickly:  LINK: Source Code Download.

The Novation series of control surfaces, such as the "ZeRO II" that I have ship with a separate program called "Automap" which is not supported for Linux.

The control surface can be used with and without Automap, but without it there is no simple way to control any of the LEDs on the control surface. The other control surfaces I own, which include a Korg NanoKontrol2, a Yamaha 02R (DAW layer) and a Bheringer BCF2000 all simply respond to control change information sent to them to update their status LEDs, encoder rings and motorised flying faders (or pickup points for non-motorised faders).

When using the Novation device in its 'advanced mode', which means without using the Automap program on an ancillary computer, it will update its leds and indicators as you adjust the associated local buttons. But as these are commonly used for track cuts and solos and record readys and so on, that are updated from other places as well, such as the GUI of a DAW or an automation track on a sequencer, they will soon become meaningless if they cannot be remotely controlled.

To solve this problem I contacted Novation by phone and email a few times. It was not clear to me that the person who handled my question understood the problem, but he did kindly send me a Novation internal document that describes the Automap protocol between the surface and the required external program. I soon realised I could quickly write my own basic version of the Automap program, sufficient to bring the Novation product up to the same basic operational level of my other control surfaces. It turned out that very little information was needed from the protocol description document, since all the basic exchanges are completely straightforward control change midi commands. However, there are several exclusive messages that would have had to be extracted using a USB sniffer program in the absence of the document. The exclusives I ended up using were to update the LCD display on the control surface and to put it into Automap mode automatically (although the latter can be done with a front panel hard button and also with a particular control change message too).

Implementation Details

When you run 'lsusb -v' to list the details of the Novation controller it reports three endpoints: two of these are the 'MIDI 1' and 'MIDI 2' ports that show up under Alsa (e.g. can be seen with the command "amidi -l") and the third is what Novation refers to as the 'hidden port'. Alsa connects perfectly and automatically to the two native ports and leaves the hidden port alone and unclaimed. Hence my mapper daemon connects to that endpoint and it then exports its own Alsa Midi port which DAWs etc must connect to, leaving the native pair of ports unused.

Control surfaces have various behaviours for the buttons: momentary, latching and so on. The most useful one, given a reasonably flexible DAW, is that they emit a CC message on both the push and release edge and that the associated LED indicator is in 'manual' mode. The word 'manual' is used on the Korg nanoKontrol but this is the mode that is sadly missing from the Novation controller and which needs the daemon to be running elsewhere.
For the infinite shaft encoders, relative output is the primary output form, sending a small +ve or -ve number as record of a rotation. I decided to integrate these inside the daemon and report a 0 to 127 absolute value to ALSA, but this is easily changed if desired.

I implemented four 'soft contexts' whereby each physical controller on the surface could have up to four mappings to actual controllers. For instance, it is then relatively easy to control 32 channels with the 8 actual channel strips on a controller. One knob is reserved to change context. On the Novation ZeRO II I used the central 'speed dial' for this adjuster. Of course, flying fader pickup points and track LED status information continues to be received while a context is not active and when that context is next selected the current settings are pushed down to the surface. For the non-motorised faders on the ZeRO II this essentially means they enter pickup mode if their physical position is wrong.

A fader that has been remotely 'moved' but which has no motor and so cannot actually move needs to enter 'pickup mode'. In pickup mode, when the user moves it, some LEDs flash and no events are sent on to the controlled target. The LEDs indicate which direction the user must move it to catch up with the current value and when it is put there it exits pickup mode.

On the Novation we have five LEDs down the left side - we use the lower two for 'too high/move down' indication and the upper two for 'too low/move up' indication. We can flash the middle one briefly when the pickup point is reached.

Further work...

TODO: Hot plug reconnection Instructions on how to make it autoload.  I may have some time at Easter to describe these.  Best regards for a happy 2014!